Ch 10 Linker Error


This topic contains 6 replies, has 3 voices, and was last updated by  thasanty 2 years, 9 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #295


    When I was running ch.10 files I got a linker error. Just saying write now that I never use the method explained in the book so I am new to how this work but back to the point. The error was something like this “DirectXTK not found” or something
    slimier to this. Before this event happen I did this:

    I download the Ch.10 files.
    Open the build Rendering.
    And run the Game solution first.

    Then the linker error happen.
    I don’t know what do. So I really need help so I can advanced in the book.


    Paul Varcholik

    Hello M. Rafi,

    Did you download only the Chapter10 folder? Because most of the code from the chapters (including Chapter 10) requires the “external” folder one directory above. More specifically, your folder structure should resemble:


    The external folder includes the DirectXTK library, Open Asset Import Library (used in Chapters 15 – 22) and the Effects 11 Library.




    Oh I thought that DirectXTK was already compiled with the files.



    Hello again.

    I did what you said and there was another linker problem. LNK1104 could not open DirectXTK.lib I don’t know what happening. I try compiling the DirectXTK project but that did not fix it. So I need help again.


    Paul Varcholik

    I’m still thinking that you might have the wrong directory structure. The external folder must be one directory above the Chapter10 folder. My last post removed the spacing in front of the directories I listed which may have been confusing.

    Here’s an image of what your directory structure should look like (if you’d downloaded the entire repository).

    Directory Structure

    Moreover, you can see what directories are in the project’s search path by looking at the Game project’s Property Pages | Configuration Properties | Linker | General | Additional Library Directories. Here’s an image of the settings used in the Chapter10 source code (the Debug configuration):

    If these settings don’t match your actual directory structure, then you won’t be able to link the associated libraries.




    Thank you for telling me this it has been troubling me for a while. Now I can get back to work. 🙂



    Hi Paul,

    I downloaded Effects11 and built it myself (debug and release versions). Everything works fine but, in the debug build, all the files that are supposed contain the ‘d’ in the end don’t have it

    I then tried compiling the Effects11 source code from the repository and I could build these files, with the ‘d’, without any problem. Is there any setting that I’m missing in VS2013? I literally followed the book 1 to 1 so I don’t know what the problem is now.
    Now I need to build the ‘Libraryd.lib’ file but my debug build’s name is just ‘Library.lib’

    Can I just rename them or change the Linker input?

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.