raptor

Forum Replies Created

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • in reply to: Shader Compile Problems #243

    raptor
    Participant

    Thank you.

    I hope that OpenGL support will get more consistent, now that I believe, mobile technology brought OpenGL back into life but also because it is a true cross platform API.

    in reply to: Shader Compile Problems #238

    raptor
    Participant

    Paul hi,

    Great intro to GL – thank you.

    I have a similar problem, the shaders do no compile from lesson 3.1.
    I have ATI catalist drivers 14.4.

    The compilation errors are intermittent, sometimes it compiles but more often than not, it either does not compile or just compiles the vartex shader.

    Below are the errors I get:

    for vartex
    ==========
    glCompileShader() failed.
    Vertex shader failed to compile with the following errors:
    ERROR: 0:9: error(#409) invalid layout qualifier applied on block member: too many locations are used.
    ERROR: error(#273) 1 compilation errors. No code generated

    for fragment
    ==============
    glCompileShader() failed.
    Fragment shader failed to compile with the following errors:
    ERROR: 0:6: error(#409) invalid layout qualifier applied on block member: too many locations are used.
    ERROR: error(#273) 1 compilation errors. No code generated

    However, If I replace the “#version 440 core” with “#version 430 core”, it always works.

    Why would this be?

Viewing 2 posts - 1 through 2 (of 2 total)